PHP4 compat fix