Issue #1125368 by tacituseu: hook_file_delete() called without valid
[project/filefield.git] / UPGRADE.txt
1
2 Upgrading from previous versions of FileField does not differ from the
3 recommended approach for other modules.
4
5 Upgrading from Drupal 5
6 -----------------------
7
8 1) Your Drupal 5 installation must be running at least FileField 2.3 before
9    migrating to Drupal 6. If your version of FileField is older than this,
10    install the latest version of FileField for Drupal 5 on your Drupal 5 site
11    and run update.php. This gets the database in a format that the Drupal 6
12    upgrade expects.
13
14 2) After ensure FileField 2.3 or higher is on your Drupal 5 site, upgrade your
15    site normally to Drupal 6. Download the latest version of FileField for
16    Drupal 6 and place it in your sites/all/modules directory.
17
18 3) Run update.php on your Drupal 6 site to upgrade FileField to the latest
19    database schema.
20
21
22 Upgrading from any previous Drupal 6 version
23 --------------------------------------------
24
25 1) Download the latest version of FileField and the filefield directory in
26    sites/all/modules.
27
28 2) Visit update.php on your site and run the update.
29
30
31 Running update.php
32 ------------------
33 Never, never, ever expand the "Select versions" fieldset and manually change
34 the update number. Drupal knows which version you are currently running and
35 automatically selects the appropriate version. If you change this number, you
36 risk running an update twice (if you select a lower number) or you'll skip
37 updates entirely (if you select a higher number). The ability to change the
38 update number was intended for developers. Due to the confusion caused by this
39 fieldset, it has been removed entirely in Drupal 7 to prevent such accidental
40 self-inflicted damage to user sites.