Add dependency.
[project/graphmind.git] / README.txt
1
2 Graphmind
3
4 Troubleshooting:
5 If you have any kind of problems with the module (especially with loading the 
6   map) check this list first:
7 - have the latest module (Graphmind)
8 - have the latest stable Services module (currently is 6.x-2.2)
9 - have the latest Amfphp module (currently is 6.x-1.0-beta2)
10 - have the Amfphp 3rd party library (http://goo.gl/txBp)
11 - have the following service submodules enabled: node_service, system_service, 
12   user_service, file_service, views_service, services_keyauth (they should be 
13   enabled on install by default)
14 - On Services > Settings > General: in the selectlist choose Key authentication, then: ONLY check [Use sessid]
15 - amfphp gateway is ok: /?q=services/amfphp gives: "amfphp and this gateway are installed correctly..."
16 - you are the admin user (uid = 1)
17 - if you are not the admin than you have the following permissions: get own user data, load node data, access content
18 - clean url is does NOT matter
19 - have flash player (> 10.0)
20 - the mindmap node in Drupal is published and you have edit/view access