#380586 by SimonEast: Updated YUI editor: Version detection not working.
[project/wysiwyg.git] / README.txt
1 /* $Id$ */
2
3 -- SUMMARY --
4
5 Wysiwyg API allows to users of your site to use WYSIWYG/rich-text, and other
6 client-side editors for editing contents.  This module depends on third-party
7 editor libraries, most often based on JavaScript.
8
9 For a full description visit the project page:
10   http://drupal.org/project/wysiwyg
11 Bug reports, feature suggestions and latest developments:
12   http://drupal.org/project/issues/wysiwyg
13
14
15 -- REQUIREMENTS --
16
17 * None.
18
19
20 -- INSTALLATION --
21
22 * Install as usual, see http://drupal.org/node/70151 for further information.
23
24 * Go to Administer > Configuration and modules > Content authoring > Wysiwyg,
25   and follow the displayed installation instructions to download and install one
26   of the supported editors.
27
28
29 -- CONFIGURATION --
30
31 * Go to Administer > Configuration and modules > Content authoring > Text
32   formats and
33
34   - either configure the Full HTML format, assign it to trusted roles, and
35     disable "HTML filter", "Line break converter", and (optionally) "URL filter".
36
37   - or add a new text format, assign it to trusted roles, and ensure that above
38     mentioned input filters are disabled.
39
40 * Setup editor profiles in Administer > Configuration and modules > Content
41   authoring > Wysiwyg.
42
43
44 -- CONTACT --
45
46 Current maintainers:
47 * Daniel F. Kudwien (sun) - http://drupal.org/user/54136
48 * Henrik Danielsson (TwoD) - http://drupal.org/user/244227
49
50 This project has been sponsored by:
51 * UNLEASHED MIND
52   Specialized in consulting and planning of Drupal powered sites, UNLEASHED
53   MIND offers installation, development, theming, customization, and hosting
54   to get you started. Visit http://www.unleashedmind.com for more information.
55