- #2120015 by TwoD: Fixed PHP Notice for CKEditor. 7.x-2.x
authorHenrik Danielsson
Thu, 20 Mar 2014 00:01:49 +0000 (01:01 +0100)
committerHenrik Danielsson
Thu, 20 Mar 2014 00:01:49 +0000 (01:01 +0100)
editors/ckeditor.inc

index de9f65b..a5a506c 100644 (file)
@@ -406,7 +406,7 @@ function wysiwyg_ckeditor_settings($editor, $config, $theme) {
   // Parse and define the styles set for the Styles plugin (3.2.1+).
   // @todo This should be a plugin setting, but Wysiwyg does not support
   //   plugin-specific settings yet.
-  if (!empty($config['buttons']['default']['Styles']) && version_compare($editor['installed version'], '3.2.1', '>=')) {
+  if (!empty($config['buttons']['default']['Styles']) && version_compare($editor['installed version'], '3.2.1', '>=') && !empty($config['stylesSet'])) {
     if ($styles = wysiwyg_ckeditor_settings_parse_styles($config['stylesSet'])) {
       $settings['stylesSet'] = $styles;
     }